Tu viejo iPhone o iPad no podrá usar el GPS si no lo actualizas antes de acabar 2019

Tu viejo iPhone o iPad no podrá usar el GPS si no lo actualizas antes de acabar 2019

Se trata de un problema crítico que Apple está solucionando.

Hoy ha sido un día movidito para Apple porque han llegado algunas novedades con la actualización de iOS 12.4 pero, además, nos ha sorprendido con un aviso a los dueños de algunos de los dispositivos más antiguos de la compañía. Concretamente los que se comercializaron en el año 2012 y anteriores.

Si tienes uno de esos iPhone o iPad, recuerda que deberás actualizarlos (cuando Apple publique el parche) antes del 3 de noviembre si no quieres que la función GPS deje de funcionar y, con ella, la posibilidad de actualizar automáticamente la fecha y la hora del dispositivo.

Un problema que se da cada 20 años

Según señala The Register, la tecnología GPS utiliza la fecha y la hora para calcular la ubicación incluyendo el número de la semana. Todos esos datos los almacena dentro de un sistema de "diez bits binarios" y cada 20 años ese contador se pone a cero, por lo que el dispositivo que está intentando usar el GPS falla y la fecha le devuelve a un año antes. Este problema se viene detectando desde el pasado 6 de abril aunque todavía no ha afectado a los iPhone e iPad de Apple más antiguos.

iPad de segunda generación.
iPad de segunda generación.

¿Y qué modelos son esos? Pues mirad: los iPhone 4s, el iPad mini de primera generación, el iPad 2 (Wifi + 3G) y el iPad 3 (Wifi + 3G) que estén actualizados a la versión 9.3.6 de iOS. Además, los iPhone 5 y el iPad 4 (Wifi+4G) deben estar actualizados a la versión 10.3.4 de iOS para poder aplicar este parche que llegará próximamente.

Normas